Egg Freckles
Notes from my Newton

Sat Mar/4 iOS Drops Support for 32-bit

Andrew Cunningham writing for ArsTechnica:

Beta builds of iOS 10.3, the first of which was issued last week, generate warning messages when you try to run older 32-bit apps. The message, originally discovered by PSPDFKit CEO and app developer Peter Steinberger, warns that the apps “will not work with future versions of iOS” and that the app must be updated by its developer in order to continue running. The apps still run in iOS 10.3, but it seems likely that iOS 11 will drop support for them entirely.

Apple has required 64-bit support on all new app submissions since February 2016, and Apple has required 64-bit support on all app updates since June 2015. Any apps that are still throwing this error have not been updated in over a year and ahalf`.

I am reading this error as a sign the next release major release of iOS will only work with iPhones and iPads with a 64-bit processor. Time to say goodnight to the iPhone 5c, iPad 4, and iPad mini 2 and earlier.